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GS-Base 8.0 
help file 

 
 
 
 
 
 
 
 

 Over 12 million records x 2047 fields in 
one table; any number of tables in one 
file.  

 Managing any type of data: numbers, 
plain text fields, long formatted text 
documents, images and any files.  

 Around 300 standard built-in formulas 
that can be used to automatically 
calculate field values, create filtering 
expressions or to create links between 
tables.  

 Extensive searching capabilities - 
searching for duplicate records or field 
values, full-text searches etc.; multiple 
sort keys.  

 Pivot tables capable of processing very 
large amounts of data.  

 Standard editing and formatting tools and 
options; predefined numeric styles and 
user-defined styles.  

 Printing tables, forms, letters and labels.  
 Sending personalized e-mail messages 

with customized attachments.  
 Strong password protection and 

encryption.  
 Saving tables to PDF.  
 A convenient and safe to handle plain zip 

file format.  
 Clean installation (no registry entries are 

required).  
 Importing, exporting and editing text, 

html, dBase III-IV, Clipper, FoxPro 2.x and 
Excel 2003 XML files 

 
 
 
 
 
 
 
 

Citadel5 
 

http://www.citadel5.com/ 
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Creating new databases 
 

To create a new database 

1. On the File menu, click New Database.  

2. Each database must contain at least one table: in the displayed Add Table dialog box, enter the 
name of the first table. 
Optionally, you can choose to import that new table from another existing file/database. 
To add other tables later, use the Database > Add Table command.  

3. If this is a new empty table, you'll be prompted to add at least one field. 
To add other fields later, use the Database > Add Field command.  

 

Field types available in GS-Base: 

Type Examples Comments 

Numeric 123 
-123 
123.09 
1.23e+02  

The actual decimal and thousand separators depend on your 
system regional settings and the current Settings > Locales menu 
selection.  

Max. positive value: 1.8+308 
Min. positive value: 2.2–308 
Precision: up to 15 digits  

Text Dog 
short text 
1 2 3 
11:34:30 PM 
7/20/2007 
P1Y2M3DT10H30M50S.000 
-P120D  

Any text containing up to 1024 characters. 

When entering date/time and time period values you must use 
one of the two string forms: 
(1) the current date/time style that you specified for a given 
field in the "Format / Style" dialog box, for example: 
7/20/2007 
7/20/2007 23:34:30 
or 
(2) the generic date/time and period string form as specified by 
www.w3.org for the (xsd schema) data/time/period data types, 
for example: 
2006-01-31 
2006-01-31T13:10:55 
2006-01-31T13:10:55.123 
2006-01-31T23:30:00+02:00 
13:10:00 
13:10:55.123 
13:10:55-00:30 
P1Y2M3DT10H30M50S.000 (which means a period of: 1 year, 2 
months, 3 days, 10 hours, 30 minutes, 50 seconds, 0 
milliseconds) 
-P120D (which means a period of minus 120 days) 
PT63H (which means 63 hours)  
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Long Text  Any text up to 16MB. By default the text is saved in the Rich Text 
(RTF) format. Right-click the field to display the context menu 
and retrieve all formatting options. 

To save only plain text (which may result in smaller files and/or 
faster loading saving if there are a lot of entries of that type), 
change the corresponding option in the Settings > Options 
dialog. 

To use the available text formatting options, select some text and 
right-click it to display the memo field context menu. 

Images/Files  Any number of images or any other files. Files other than *.jpeg, 
*.png, and *.bmp are represented as icons associated with their 
file extensions. 
Use the context menu or the Settings > Options dialog box to 
turn on/off displaying thumbnails and/or file information (file 
name, size, modification date). 

If you insert some link *.lnk files linking to some disk files and if 
you later change the location of those target files, you can 
specify the new shortcut path globally in the Settings > Options 
dialog. 

To open or print a given inserted object, double-click or right-
click it. 

To modified an inserted file, you must save it outside the field 
(e.g. using the drag-and-drop functionality or the "Save As" 
command), modified it in the associated application and insert it 
back into the field. 

 
 
 
 
GS-Base zip database file format 
 

GS-Base databases are zip archives containing the following file categories: 

1. Database records stored as 

[table name].txt 

text files. These are plain comma-separated UTF-8 text files containing field names in the first row 
and records in the subsequent rows. 
You can edit these files manually without GS-Base using any text editor capable of saving using the 
UTF-8 encoding. 
If you delete such a file from the zip file, GS-Base will displays an empty table. 
If you insert any text (*.txt, *.csv, *.tsv, *.tab) file into the zip, GS-Base will detect and report a new 
table(s) and will enable you either to setup and add it to the database or to retain it in the zip file as 
an unused file. 
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2. Binary field content subfolders containing long text or any objects (including links to objects). Each 
such subfolder has the following form: 

[table name].r[8-digit record number]f[5-digit field number]  

For Long Text fields, each such subfolder contains one *.rtf or *.txt file. 
For Images/Files fields, each such subfolder contains any number of any files. 
You can edit/add/remove these files manually without GS-Base and add/remove/edit subfolders or 
their names. 

3. One configuration config.dat file containing various information about the database: the order of 
tables, page settings and formatting. 
If you delete this file manually, GS-Base can still use all the record tables and binary fields and re-
import them automatically as if they were new tables. 

4. One META-INF/manifest.txt file containing the list of all files used by the database. If the file is 
encrypted, that file also contains various encryption parameters. 
If the database is not encrypted, deleting this file doesn't affect the database. 
If the database is encrypted, you must not alter that file in any way or you'll risk loosing the data. 

5. Any number of any files not used by GS-Base that you can drag-and-drop into the database zip file 
manually. 
If the Settings > Options > Show the unused files list option is on, GS-Base will report detecting such 
files. When the database zip file is saved, all such unused files are stored in the separate unused/ zip 
subfolder. 

 
 
Editing field contents 
 

To edit Numeric and Text field contents 

Do one of the following: 

 Press Enter, F2 or any letter/digit key.  
 Double-click a given field.  

You can enter up to 1024 characters in the standard Text fields. Binary (Long Text and Images/Files) fields 
can contain text of any size or any number of objects of any size. 
To accept changes when editing records in tables and forms, press Enter or any of the cursor keys. To enter a 
new line in the edited cell, press Ctrl+Enter. To cancel changes, press Esc. 
Binary fields are saved automatically after each performed action. If a given binary field is not empty, the 
respective table or form field contains a single asterisk (*). If you want to delete the entire Long Text or 
Images/Files field content at once removing the respective entry from the database zip file, simply delete 
that asterisk.  

If you set some numeric or date/time format for a given field, GS-Calc will try to interpret the data according 
to that format. 
The date/time style can be applied to Text fields only.  

 
Note: 
If you want to apply the date format to a text field that already contains some non-standard (that is, other 
than YYYY-MM-DD) text strings, you should first use the Edit >Convert > Text Strings To Date Strings 
command (or re-enter each date individually). This step is required to ensure correct sorting of such a field.  
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To move/copy/paste field contents 

Tables: Place the mouse cursor over the top edge of the selection and drag it. 
You can move the data within the same window, different windows or applications - by default GS-Base 
copies (and provides to other applications) the table data as text and bitmaps. 
If you drop a file(s) within the table view, GS-Base either paste the file path if the cursor was over a hyperlink 
field or will display a dialog enabling you to choose into which Images/Files field that file(s) should be 
inserted.  

Binary Fields: The standard Windows drag-and-drop procedure applies except that the dropped objects are 
always copied, not moved. 
If your want to insert a link into an Images/Files field, press and hold down the Ctrl+Shift keys.  

 
To fill a given range with some values 

1. Copy the source cell or range.  
2. Select the destination range. The destination range cannot contain more columns than the source 

range. If it does, the additional columns are ignored and won't be filled.  
3. Paste the copied data.  

 
To use a drop-down list to enter data 

Use the Format > List command and specify which list should be used for a given field(s). The same list can 
be shared by any number of fields in any number of tables in one database. One database file can contain up 
to 255 lists. The number of list items is unlimited.  

 
To use a "Date and Time Picker" control to enter data 

The control can be displayed for each text field that (1) is formatted as "Date" and (2) doesn't have any drop-
down list attached to it at the same time. 
This edit control can be enabled/disabled in the Settings > Options dialog. The following shortcut keys are 
used by the date time picker control:  
 

Arrows keys Changes the active control field and/or changes control field values 

End and Home Sets the maximum and minimum values for the current part of the date (a year, month 
or day) 

Plus and Minus Increments/decrements the current part of the date (a year, month or day) 
Alt+Down Displays the "Month Calendar" control. Same as clicking the "drop-down" arrow 
PageUp, 
PageDown If the "Month Calendar" control is active, moves to the previous/next month 
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Calculated fields, links between tables 
 

To create a calculated field 

Use the Database > Field Properties command for a given plain text or numeric field and enter the desirable 
formula. 
To browse all built-in functions, their categories and examples, click the Formulas button. 

 

Formulas available in GS-Base are similar to those used in spreadsheets with a few exceptions:  

 Cell references are replaced by field names which refer to the record where a given formula resides.  
 The range ":" operator is not available.  
 References to other tables via the "!" and "_" operators are not available. Instead, there is a 

separate category of functions: Cross-table summarizing & lookup functions that groups functions 
accessing data from other database tables in the same database.  

To learn more on the formula syntax, please see: Entering formulas 

Table cells representing calculated fields display calculation results only and can not be edited. They are 
displayed with a slightly different background color within the table and form views. 
Calculated fields are updated in the following situations:  

 After a given record is modified, calculated fields within that records are updated.  
 After choosing the Tools > Update Data (F9) command, calculated fields for all records in the current 

table are updated.  

Notes: 

 Make sure the type of the value returned by that formula matches the field type.  
 Formulas may return various error values. To find records containing such values, use the 

informational functions. 
Generated error values are not saved in the database and are not preserved between sessions.  
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To create links between tables 

Linking to another table is a special case of using a calculated field and the vLookUp_ex function from the 
Cross-table summarizing & lookup category. It behaves similarly to the standard spreadsheet vLookUp 
function you may already know. 

For example, the following formula (used in the "orders" table) searches the "ProductID" field of all records 
in the "products" table for the specified product id number and returns the name of the product stored in 
that "products" table. 
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To summarize or to count values from other tables 

To do this, use the sumIf_ex and countIf_ex functions from the Cross-table summarizing & lookup category. 

Examples: 

(1) To find the total value of all orders placed by a given customer, you can use (in the "customers" table) the 
following formula that searches the "id" field of all records in the "orders" table for the specified customer id 
number and then summarizes the "Total" value from the found records. 

 

(2) To find the total number of all orders placed by a given customer, you can use (in the "customers" table) 
the following formula that searches the "id" field of all records in the "orders" table for the specified 
customer id number and counts the found records. 
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Using Pivot Tables 
 

Pivot tables enable you to quickly and easily obtain and visualize various statistical information about data 
coming from flat source record tables. This includes (but is not limited to) counting, summarizing, sorting or 
finding partial maximum/minimum values. In GS-Base you can create up to 100 pivot tables for each record 
table. To create a new table, click View > Pivot Table View and in the opened pivot tables pane click Pivot 
Table > Add New Pivot Table or - if there no other tables selected yet - simply click the Setup button. 

Quick start 

Open the included sample "sample.zip" database and choose the "customers" table. 
The records contains among other the "Country" and "City" fields. 

To find out what is the number of customers from particular countries: 

1. Open the Pivot Table Setup dialog.  
2. Choose the "Country" database field as the only Row field.  
3. click OK.  

 

 

To find out what is the number of customers from particular countries and how many of them come from 
given cities in that country: 

1. Open the Pivot Table Setup dialog.  
2. Choose the "Country" database field as the first Row field.  
3. Choose the "City" database field as the second Row field.  
4. click OK.  
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Open the included sample "sample.zip" database and choose the "orders" table. 
The records contains among other the "ProductName" and (order) "Date" fields. 

To find out what are the numbers of sold products and how the number sales looked like in given days: 

1. Open the Pivot Table Setup dialog.  
2. Choose the "ProductName" database field as the only Row field.  
3. Choose the "Date" database field as the only Column field.  
4. click OK.  

 

 

 

To find out what are the numbers of sold products and how both the number of sales and the sales totals 
looked like in given days: 

1. Open the Pivot Table Setup dialog.  
2. Choose the "ProductName" database field as the only Row field.  
3. Choose the "Date" database field as the only Column field.  
4. Choose the "Total" database field as the first Data field and select the Count function for it.  
5. Choose the "Qty" database field as the second Data field and select the Sum function for it.  
6. click OK.  
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Default field values 
 

To specify a default value for a given Text/Numeric field 

Open the Database > Field Properties dialog, select the Default value option and enter the desirable value 
which can be: 

 Unformatted number in case of a numeric field.  
 Any text string in case of a text fields. If that text field is formatted as "Date", the default value 

should represent the generic date/time string: YYYY-MM-DD.  

 
To insert field's default value 

Select a range of fields and/or records and use the Insert > Default Value (Ctrl+T) command. Default values 
are inserted to all empty fields within the selection. 

 

Selecting fields and records, scrolling, shortcut keys 
 

To select a range of fields and/or records in the table view 

Do one of the following: 

 Use the mouse cursor.  
 Press Shift and use any of the scrolling keys.  
 Press Ctrl+Space to select the current field in all records  
 Press Shirt+Space to select the entire current record  

To jump to the desirable record or to select a record range 

Click the Record field on the bottom toolbar or press Ctrl+G, then enter the record number or a record range 
(as two numers separated by ":") and press Enter. 
You can also use menus attached to the "Previous"/"Next" buttons to scroll up or down to some specific 
records (e.g. next empty, non-empty, the same etc.).  

Navigation / shortcuts keys 

Up, Down, Left, Right scroll by one row/column 

Ctrl+Up, Ctrl+Down Go up or down to the next empty field 

Alt+Ctrl+Up, Alt+Ctrl+Down Go up or down to the next empty with the same content 

PgUp, PgDn, Alt+PgUp, Alt+PgDn scroll by one page vertically or horizontally 

End last non-empty column 

Home first column 

Ctrl+End last non-empty row 

Ctrl+Home first row 

Ctrl+PgUp previous table (in the print-preview mode: previous page) 

Ctrl+PgDn next table (in the print-preview mode: next page) 
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Other shortcuts 

Ctrl+B bold font 

Ctrl+I italic font 

Ctrl+U underline font 

Ctrl+K strikeout font 

F6 next pane  

Shift+F6 previous pane  

 
To use the 'auto-scroll' function 

Click the worksheet window using the mouse wheel button and choose the desirable scrolling speed and 
direction by moving the mouse cursor around the clicked point. 

 

Formatting 

Fonts 

The Font dialog box enables you to specify all basic font attributes including its name, size, weight, slant (the 
italic style), the underline and strikeout options and the font color.  

To revert to the default settings, click the Reset button.  

Style 

You can use the following standard numeric styles and their options: 

 Default 
(No specific formatting. Numbers with more than 15 digits are displayed in the exponential-scientific 
format.)  

 General  

o decimal places (0 to 14)  
o leading zeros (0 to 14)  
o thousand separator  
o displaying negative numbers in red or in parenthesis  

 Currency  

o currency symbol position  
o currency symbol  
o displaying negative numbers in red or in parenthesis  

 Accounting  

o currency symbol  

 Date  

o date pattern  
o using fixed or system dependent year/month/day order  
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 Time 

o time/period pattern  

 Date/Time 

o date pattern  
o time pattern  
o using fixed or system dependent year/month/day order  
o date/time order  

 Percent 

o decimal places (0 to 14)  

 Fraction 

o either a fixed denominator value (1 to 9,223,372,036,854,775,807) or a fixed number of 
denominator digits (1 to 19)  

 Scientific 

o decimal places (0 to 14)  
o a fixed exponent value  

 
Alternatively, you can use a user-defined numeric format. To do this, simply enter the desirable style pattern 
in the Style dialog. If you need to re-use it, you can save it as a new user style with a new name. To learn 
more about style patterns, please see how the standard styles are defined. For example, the accounting 
format is defined as:  

_(\$* #,##0.00_);"($"* #,##0.00\);_(\$* \-??_);_(@_)  

and the fraction format with the fixed denominator (4) can be defined as:  

?\ ?/\4  

User-defined formats allow you to specify font colors for numbers that meet some conditions. For example:  

[green]#.#;[red]\-#.#;[blue]#.#;[gray]@  

displays positive numbers in a green font, negative numbers in red, blue zeroes and gray text labels,  

[red][<10]#0.00;[yellow][<=50]#0.0;[green][<400]##0;[magenta][>=400]#00  

displays numbers less than 10 in a red font, numbers less or equal to 50 in a yellow font, numbers less than 
400 in a green font and numbers greater or equal to 400 using a magenta font.  
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Color values can be expressed as RGB values (for example, [red][<10]#0.00 is the same as 
[#FF0000][<10]#0.00) or by one of the following color names:  

black [#000000] maroon [#800000] 

green [#008000] olive [#808000] 

navy [#000080] purple [#800080] 

teal [#008080] gray [#808080] 

silver [#C0C0C0] red [#FF0000] 

lime [#00FF00] yellow; [#FFFF00] 

blue [#0000FF] fuchsia [#FF00FF] 

aqua [#00FFFF] white [#FFFFFF] 

 
Alignment 

The Alignment dialog box enables you to specify the following options:  
 

 how to display text strings that exceed the cell width,  
 horizontal and vertical indents (the distance measured from the cell contents to the cell boundaries),  
 text rotation,  
 horizontal (left, center, right) and vertical (top, center, bottom) alignment; unformatted cells display 

vertically centered, right-aligned numbers and vertically centered, left-aligned text strings.  
 
To revert to the default settings, click the Reset button.  

 
Hyperlink 

Treats the field contents as a hyperlink. Clicking that field opens the link. The link can be a www address, e-
mail address or a regular file on your local disk. 
You can explicitly specify the link type/protocol adding one of the following prefixes: 

 http://  
 https://  
 file://  
 mailto:  
 ftp://  
 gopher://  
 nntp://  
 news://  
 wais://  
 telnet://  
 prospero://  
 res://  
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Drop-down lists 

You can use the Drop-down list dialog box to set the drop-down list format and/or to manage (create, edit, 
delete) lists in the current workbook.  

When editing a field with some drop-down list attached to it, you can quickly choose some predefined cell 
value instead of re-typing it. 
To set that format, simply choose an existing list or click the New List button.  

To add list items, enter them in the List Items edit field: one item in one line.  

If you choose the Append new items option, each unique value entered in the corresponding field(s) will be 
added to the list automatically. 
If the Sort items option is not selected, the list will display all its elements in the same order as they were 
added/entered.  

One list can be used by any number of fields in any table. You may create up to 100 list in one database file. 
To move lists between files, you have to copy/paste the data from the List Items edit field.  

 

Searching / Filtering Records 
 

To filter records and search Text and Numeric fields for a text string or text pattern 

Scroll to a given field and press Ctrl+Enter or use the Tools > Set Search Filter command. 

Search filters are regular spreadsheet formulas similar to those used in GS-Calc and other spreadsheets with 
a few exceptions: 
(*) cell references are replaced by field names, 
(*) the range ":" operator is not available 
(*) direct references to other tables via the "!" and "_" operators are not available. 

To learn more on the formula syntax, please see: Entering formulas 

When searching, such a formula is evaluated for each record. A record is considered to meet the searching 
criteria if each entered formula returns a value other than 0 for each . 

In the displayed Search dialog box you can: 

(1) quickly specify some search parameter(s) and search mode ('patter', 'equal', 'less than', 'between' etc.) 
and let GS-Base build the formula for you, for example: 
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or 

(2) manually enter the entire formula, for example: 
 

 

If you use some specific filters frequently, you can save it as a search key and then simply choose the key 
name from the toolbar Search Key drop-down list instead of re-entering the search filters individually each 
time. 
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To clear all current search filters, choose the (None) search key or use the Tools > Remove All Filters 
(Ctrl+Backspace) command. 

 
To filter records and search Long Text or Images/Files fields for a text substring 

Scroll to a given field and press Ctrl+Enter or use the Tools > Search Field command. 
Enter the text to search for. For Images/Files fields, GS-Base searches the names of the files inserted into 
those fields. The specified text string must be a substring of the field text.  

| 
To filter records and search for duplicated field values 

Scroll to a field or select a range fields which should be searched and use the Tools > Find Duplicates 
command. 
To find entire duplicated records, select an entire row clicking the row heading or pressing Shift+Space. 

 
To filter records and search for flagged records 

Use one of the Tools > Find Flagged Records commands. 
By default, when installing GS-Base creates only one "Highlighted" flag type that causes displaying a record 
in red. You can define up to 5 flag types for each database using the Tools > Record Flags command. 

 
To filter records and display the complement of the current record set 

To find the complement of the current record set (that is, all the records that are not included in the current 
record set), use the Tools > Find Complement command. 

 
To search all the text and numeric fields in current record table without filtering records 

Use the Edit > Find (F3) command and in the displayed Search Toolbar enter the desirable substring. This 
search function simply scrolls to the subsequent found table cell values. It doesn't perform any filtering. 
The search toolbar also enables you to replace found substrings. If you want to perform such a find-and-
replace action for one field only, select the column clicking its header. 

 

Sorting 
 

To sort records 

Use the Tools > Sort command and specify the sort key 

or 

click the Sort toolbar button. If you want to define a multi-field sort key, press and hold down the Shift key. 
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Printing tables, forms and labels 
 

To print tables, forms, letters or labels 

Choose the desirable print mode in the Print > General dialog box. 

Depending on your selection, you will be able to specify several additional printing options for each print 
mode. 

Table: This is the default print mode. Use it to print selected records in plain tables. 
Note that neither Long Text nor Image/File are printed in that mode. 
To specify which field should be printed, click the Table tab. 

Forms: GS-Base prints each record as a form. There are two form variants: 
(1) one-page forms where the first Long Text or Image/File and the remaining Text/Numeric fields are 
printed "side by side" on a single page, 
(2) multi-page forms where all Long Text or Image/File fields are printed on the subsequent pages after all 
Text/Numeric fields, one field per page. 
To specify which field should be printed and to turn on/off printing one-page forms, click the Labels tab. 

Letters: GS-Base prints a user-defined RTF document containing references to record fields. 
One copy of such a document is printed for each record in the current record set. The embedded fields can 
be of any type save Image/File. 

Labels: You must define the required label format. To do this, click the Labels tab, then click the Add button 
and enter the name of your new label format. 
 

 
 
Next specify the number of columns and rows of labels on one page and insert the fields you want to print 
on each label. 
When editing labels you can move or resize the fields. To select a group of fields press Shift and click 
subsequent fields or press down the left mouse button and drag the mouse cursor. The font is determined 
by the current format of each field. 
To create a new label format that is based on some existing one, use the Copy and Paste buttons: 
 

 
 
To print a test page, click the Test button. 

Select the desirable Page Range option. You can print all found records, selected range of records or 
particular pages. 

 
To print selected pages 

Choose the Pages option in the Print > General dialog box and specify the list of pages to print. 
The list can contain single pages or page ranges separated by commas. For example: 1,2,4-8,10 
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To print more than one page on a single paper sheet 

Specify the number of printed pages in the Pages per sheet fields in the Print > Layout dialog box. For 
example, if you choose two columns and three rows, one sheet will contain (up to) six pages. 

To include a table name, page number, date etc. in the printed pages headers and footers 

In the Print > Layout dialog box, enter the header/footer text inserting the following special codes: 

&p Prints the current page number 

&p+number Prints the current page number plus 'number' 

&p-number Prints the current page number minus 'number' 

&n Prints the total number of pages 

&m Prints the current paper sheet number (different than &p when printing many pages on one 
sheet) 

&f Prints the full file path 

&a Prints the name of the printed table 

&d Prints the current date 

&t Prints the current time 

&g Prints the file modification date 

&z Prints the file modification time 

&& Prints a single ampersand 

 
To format the header/footer text 

In the Print > Layout dialog box, enter the header/footer text inserting the following special codes: 

&l Left-aligns the following text 

&c Centers the following text 

&r Right-aligns the following text 

 
To change the view scale in the print-preview window 

Click the Zoom In button and pressing the right mouse button select a rectangle that should be zoom in. 

 

Password protection and encryption 
 

To password-protect and encrypt all data in the database zip file, use the File > Protect command and 
specify a password consisting of at least 6 characters. 

To encrypt the data, GS-Base currently uses the Twofish CFB algorithm. All encryption parameters are saved 
in the META-INF/manifest.txt text stream in the database zip file.  



 20 

If the database is encrypted, you must not alter the META-INF/manifest.txt file in any way or you'll risk 
loosing the data.  

Files added by users manually to the zip that are not used/imported by GS-Base remain unencrypted and are 
moved to the "unused/" zip subfolder. If a database is encrypted and protected, there is a green shield 
symbol displayed on the status bar. 

 

Saving files: PDF files 
 

To save data in the PDF format:  

 Use the File > Save Table As PDF and File > Save All Tables As PDF commands. 
The former saves the current table and the later - all tables of the database. You can change the 
page layout and other content options using the File > Page Settings command.  

Note: When saving a PDF file GS-Base maps all fonts used in a workbook to a standard set of 14 PostScript 
Type 1 fonts which are required to be present in every PDF viewing application and in every operating 
system. 

To specify advanced PDF save options, use the File > Advanced PDF Save Options command. GS-Base 
enables you to enter custom character encoding lists for various languages. Typically it's necessary for non-
English languages to display some local/national characters correctly. You can also change/re-define the 
default PDF "Windows Ansi" character set the way you want. The lists correspond to parameter of the PDF 
font object /Differences [...]. When saving a PDF file each defined custom encoding list is applied 
automatically based on the current Windows language settings. 

For example, the full iso-8859-1 list is: 

32 /space /exclam /quotedbl /numbersign /dollar /percent /ampersand /quotesingle 
/parenleft /parenright /asterisk /plus /comma /hyphen /period /slash /zero /one 
/two /three /four /five /six /seven /eight /nine /colon /semicolon /less /equal 
/greater /question /at /A /B /C /D /E /F /G /H /I /J /K /L /M /N /O /P /Q /R /S 
/T /U /V /W /X /Y /Z /bracketleft /backslash /bracketright /asciicircum /underscore 
/grave /a /b /c /d /e /f /g /h /i /j /k /l /m /n /o /p /q /r /s /t /u /v /w /x /y /z 
/braceleft /bar /braceright /asciitilde /bullet /Euro /bullet /quotesinglbase /florin 
/quotedblbase /ellipsis /dagger /daggerdbl /circumflex /perthousand /Scaron 
/guilsinglleft /OE /bullet /Zcaron /bullet /bullet /quoteleft /quoteright /quotedblleft 
/quotedblright /bullet /endash /emdash /tilde /trademark /scaron /guilsinglright 
/oe /bullet /zcaron /Ydieresis /space /exclamdown /cent /sterling /currency /yen 
/brokenbar /section /dieresis /copyright /ordfeminine /guillemotleft /logicalnot 
/hyphen /registered /uni203E /degree /plusminus /twosuperior /threesuperior 
/acute /mu /paragraph /periodcentered /cedilla /onesuperior /ordmasculine 
/guillemotright /onequarter /onehalf /threequarters /questiondown /Agrave /Aacute 
/Acircumflex /Atilde /Adieresis /Aring /AE /Ccedilla /Egrave /Eacute /Ecircumflex 
/Edieresis /Igrave /Iacute /Icircumflex /Idieresis /Eth /Ntilde /Ograve /Oacute 
/Ocircumflex /Otilde /Odieresis /multiply /Oslash /Ugrave /Uacute /Ucircumflex 
/Udieresis /Yacute /Thorn /germandbls /agrave /aacute /acircumflex /atilde /adieresis 
/aring /ae /ccedilla /egrave /eacute /ecircumflex /edieresis /igrave /iacute 
/icircumflex /idieresis /eth /ntilde /ograve /oacute /ocircumflex /otilde /odieresis 
/divide /oslash /ugrave /uacute /ucircumflex /udieresis /yacute /thorn /ydieresis 

and the encoding differences for East European > Polish character set will be: 

32/space 40/parenleft/parenright 44/comma/hyphen/period/slash/zero/one/two/three/four 
/five/six/seven/eight/nine/colon 65/A/B/C/D/E/F/G/H/I/J/K/L/M/N/O/P 82/R/S/T/U 
87/W/X/Y/Z 97/a 99/c/d/e/f/g/h/i/j/k/l/m/n/o/p 114/r/s/t/u 119/w 121/y/z 140/Sacute 
156/sacute 163/Lslash 165/Aogonek 179/lslash 185/aogonek 191/zdotaccent 209/Nacute 
230/cacute 234/eogonek 241/nacute 243/oacute  
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Opening and saving text files 
 

To open a text file 

Use the File > Open command and choose Text from the File of type list. Next, specify additional text file 
options: 

Field separator A single character used to separate fields in one line. 

Fixed field widths A list of fixed field width values. For example: 
10,30,15,40 
If not all widths are specified, the remaining fields are assumed to contain 1024 
characters. 

Quoting symbol A symbol used to delimit fields containing separator characters. 
Fields that contain quoting symbols must be delimited by quoting symbols as well. The 
inner marks must be doubled in such a case. For example, if some row contains the 
following four values/fields: 

a,b 
c 
d 
="a" & "1" 

they will be saved as 

(1) a,b|c|d|=""a"" & ""1"" 
(2) "a,b",c,d,"=""a"" & ""1""" 
(3) a,b;c;d;"=""a"" & ""1"""  

where the double quotation mark (") is the quoting symbol and the separators are 
respectively: 
(1) | 
(2) , 
(3) ;  

Encoding Specifies the text encoding for a given text file: UTF-8, ANSI 8-bit, ISO/OEM. 

First row contains 
field names 

Specifies whether text strings from the first line of the file should be treated as field 
names. If you clear this option when reading a text file, GS-Base will use simple 
"field_nnnn" names.  

Convert data to 
numeric fields 
wherever possible 

If you check this option, a column containing only text strings that can be converted to 
numbers (without formatting) will be treated as a numeric database field. Otherwise 
all such columns will be imported as text fields (and will be sorted and searched as 
plain text fields). 
You can also change the field type after you import the file using the Database > Field 
Properties command.  

To save a text file 

Use the File > Save Recordset As command and choose Text from the File of type list. Next, specify the same 
additional text file options as above. 

Note: When saving a text file, GS-Base saves only filtered records from the active table. 
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Related Topics  

Saving PDF files; Opening and saving html files; Opening and saving xBase files; Opening and saving Excel 
XML files  
 

Opening and saving html files 
 

To open a html file 

Use the File > Open command and choose HTML from the File of type list. Next, specify which table you 
want to load. 

 
To save records to a html file 

Use the File > Save Recordset As command and choose HTML from the File of type list. Next, specify 
additional html file options: 

Template Specifies an optional HTML file that should be used as a template. The file must contain 
a TABLE element with the ID attribute set to 'gsbase', e.g. 

<TABLE id="gsbase"> ... 

GS-Base will empty that table and fill it with the specified records. All attributes of the 
TR, TH and TD tags are removed; you should specify column formatting using the 
COLGROUP and COL tags. 

If you don't provide any template, GS-Base will create and save a basic/minimal HTML 
document containing a table filled with records. 

Note that Image/File fields are not saved. 

Saved fields Specifies which fields should be saved. 

Save duplicated 
field values as 

Specifies a text string that should be used to replace the same values occurring in the 
same field and subsequent records. 

Encoding Specifies text encoding. Currently the only valid value is UTF-8. 

First row contains 
field names 

If you check this, the first row of the saved table will contain field names as TH 
elements.  

 
Related Topics 

Opening and saving text files; Opening and saving xBase files, Opening and saving Excel XML files  
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Opening and saving xBase files 
 

To open an xBase file 

Use the File > Open command and choose dBaseIII, dBaseIV, FoxPro 2.x or Clipper from the File of type list. 
Next, specify additional xBase file options: 

Encoding Specifies the text encoding for a given xBase file: ANSI 8-bit or ISO/OEM. 

 
To save an xBase file 

Use the File > Save Recordset As command and choose dBaseIII, dBaseIV, FoxPro 2.x or Clipper from the 
File of type list. 

Note: When saving an xBase file, GS-Base saves only filtered records from the active table. 

 
Related Topics 

Saving PDF files; Opening and saving text files; Opening and saving html files; Opening and saving Excel XML 
files  

 

Opening and saving Excel XML files 
 

To open an Excel 2003 XML file 

Use the File > Open command and choose the Excel XML format from the File of type list. 

 
To save an Excel 2003 XML file 

Use the File > Save Recordset As command and choose the Excel XML format from the File of type list. 

Note: When saving an Excel XML file, GS-Base saves only filtered records from the active table. 

 
Related Topics 

Saving PDF files; Opening and saving text files; Opening and saving html files; Opening and saving xBase files  
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Settings 
 

All GS-Base global settings are stored in the settings.xml files. Their location depends on how you install the 
application. If you choose the portable installation, the settings file will be saved directly to the installation 
folder. Otherwise they're saved to the Windows local application data (e.g. C:\Documents and 
Settings\username\Local Settings\Application Data\GS-Base). 

You can use the Settings > Save - Load Profile commands to save or load different settings profile files. 

The following data can be specified in the Settings > Options dialog:  

 
Undo/Redo level 

The number of actions that can be undone via the Edit > Undo-Redo commands. 
A very high undo level causes greater memory usage if some very large copy/paste operations are 
performed. 
The drag-and-drop operation is treated as a two-step action so the minimum undo level is 2. 
Valid range: <2, 200> 
Default: 20 

Used processor cores (threads) 

The number of processor cores that GS-Base is allowed to use when updating calculated fields (Tools > 
Update All Calculated Fields) and when filtering records (excluding full-text searches in memo fields). 
Valid range: <1, 10> 
Default: 2 

Wrap text in memo fields 

Text displayed in Long Text fields is wrapped according to the edit window. 
Default: On 

Plain text in memo fields 

Text entered in Long Text fields is saved in the plain UTF-8 *.txt text format rather than in the rich text *.rtf 
format. 
Using plain text may noticeably reduce memory usage if there is a very large number of Long Text entries in 
the database zip file. 
Default: Off 

Show last line of text in memo fields 

By default after loading a memo field content the beginning of the text displayed. 
If you check this option, the text cursor will be automatically scrolled to the bottom of the text. 
Default: Off 

Display thumbnails 

Specifies whether images in Images/Files fields should be displayed as thumbnails. 
Default: Off 
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Show image labels 

Specifies whether images and files icons in Images/Files fields should be displayed along with the file 
information. 
This includes the file name, size and the last modification date (at the moment when the file was inserted). 
Default: On 

Use date time picker when editing dates 

Check this option to use the date-time picker control instead of the plain edit control. 
This options applies to text fields that are formatted as Date and that don't use the drop-down list 
functionality. 
Default: On 

Show unused zip file list 

If you manually drag-and-drop any files to a given database zip file, GS-Base will detect such files and show 
the list of them. 
If the option is off, GS-Base will silently load and save back such unused files. 
Default: On 

Default pivot function 

Specifies a function that will be used by each new or existing pivot table that doesn't have any data field 
defined. 
The default count function results in counting all subsequent values of the specified row field(s). 
Default: Count 

AutoSave 

Specifies the period of (user) inactivity after which GS-Base will automatically save the open database (if it's 
modified). 
Default: Never 

AutoClose 

Specifies the period of (user) inactivity after which GS-Base will automatically close the open database. 
Modified databases are saved before closing. 
Default: Never 

After pressing Enter 

Specifies whether (and how) to scroll the current table cell after you finish editing and press Enter. 
Default: No action 

Start folder 

Specifies the folder displayed in the Open File dialog box when you open it for the first time (after launching 
GS-Base). 
Default: Empty 
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Relative shortcut path 

If you insert some link *.lnk files into Images/Files fields and later change the location of the target objects 
that the links are connected to, you can "overwrite" such broken links globally specifying that path. 
Default: Empty 

No-deflate file types 

Specifies the list of file types (stored in Images/Files fields) that will be saved in the database zip file without 
compression. The list should contain file types that contain already compressed data. This can improve 
loading/saving times without worsening the overall compression factor. 
Enter the extensions in the *.ext1;*.ext2;... form. 
Default: *.png;*.jpg;*.gif;*.pdf;*.zip;*.ods 

Windows opacity 

Specifies the opacity of all dialog boxes displayed by GS-Base. Decreasing this value means making the 
windows more transparent. 
Valid range: <10, 100> 
Default: 100% (no transparency) 

Default font 

Specifies the default font name. The font specified here will be used by database tables, forms, binary edit 
windows and pivot tables. 
Default: Arial 

 

Managing the list of "recently-used" files 
 
After closing the database window, GS-Base displays the list of recently used databases. 

To open a given file, click the corresponding link or press space. 

To change the icon associated with a given file, click that icon. 

To delete a file from the list, right-click it and use the Remove command from the context menu. 

 

Support 
 

If you have any questions, comments or suggestions, please contact  

E-mail: info@citadel5.com 
Web: http://www.citadel5.com  

 Please allow up to 24 hours for a response.  
 Do not send very large attachments without prior consent.  


