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GS-Base

� Over 12 million records x 2047 fields in one table; any number of 

tables in one file. 

� Managing any type of data: numbers, plain text fields, long formatted 

text documents, images and any files. 

� Around 300 standard built-in formulas that can be used to 
automatically calculate field values, create filtering expressions or to 

create links between tables. 

� Extensive searching capabilities - searching for duplicate records or 

field values, full-text searches etc.; multiple sort keys. 

� Pivot tables capable of processing very large amounts of data. 

� Standard editing and formatting tools and options; predefined numeric 

styles and user-defined styles. 

� Printing tables, forms, letters and any labels. 

� Sending personalized e-mail messages with customized attachments. 

� Strong password protection and encryption. 

� Saving tables to PDF. 

� Safe zip file format - data can be browse even without the program. 

� Clean installation (no registry entries are required). 

� Importing, exporting and editing text, xml, html, dBase III-IV, Clipper, 

FoxPro 2.x and Excel 2003 XML files. 

Introducing GS-Base
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To create a new database

1. On the File menu, click New Database.

2. In the displayed Add Table dialog box, enter the name of the first table.

Optionally, you can choose to import that new table from another existing file/database 
in any of the supported file formats.
To add other tables later, use the Database > Add Table command.

3. If this is a new empty table, you'll be prompted to add at least one field.

To add other fields later, use the Database > Insert Field and Database > Append 
Field command. 

Field types available in GS-Base:

Creating new databases

Type Examples Comments

Numeric 123
-123
123.09
1.23e+02

The actual decimal and thousand separators depend on 
your system regional settings and the current Settings
> Locales menu selection. 

Max. positive value: 1.8+308
Min. positive value: 2.2–308
Precision: up to 15 digits

Text Dog
short text
1 2 3
11:34:30 PM
7/20/2007

P1Y2M3DT10H30M50S.000
-P120D

Any text containing up to 8169 bytes (*).

When entering date/time and time period values you 

must use one of the two string forms:
(1) the current date/time style that you specified 
for a given field in the "Format / Style" dialog box, for 
example:
7/20/2007

7/20/2007 23:34:30
or
(2) the generic date/time and period string form 
as specified by www.w3.org for the (xsd schema) 
data/time/period data types, for example:

2006-01-31
2006-01-31T13:10:55
2006-01-31T13:10:55.123
2006-01-31T23:30:00+02:00

13:10:00
13:10:55.123
13:10:55-00:30
P1Y2M3DT10H30M50S.000 (which means a period of: 
1 year, 2 months, 3 days, 10 hours, 30 minutes, 50 

seconds, 0 milliseconds)
-P120D (which means a period of minus 120 days)

Creating new databases
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(*) - The maximum number of bytes refers to the UTF-8 string representation. In practice, for 
users using Latin characters this value equals to the number of characters, however for e.g. far-
east languages characters require a few byte UTF-8 sequences hence the character limitation will 

be smaller.

PT63H (which means 63 hours) 

Long Text Any text of any size. By default the text is saved in the
Rich Text (*.rtf) format and can contain any supported 

formatting and inserted graphics or objects.

Right-click the field to display the context menu and 
available editing commands and options.
Clicking the Edit in External Application command 
you can edit the text in the application associated with 
the *.rtf or *.txt format. Changes are saved 

automatically after choosing the Save command in that 
application.

To save only plain text (which may result in smaller 
files and/or faster loading saving if there are a lot of 
entries of that type), change the corresponding option 
in the Settings > Options dialog.

Images/Files Any number of images or any other files. Files other 

than *.jpeg, *.png, and *.bmp are represented as 
icons associated with their file extensions.
Use the context menu or the Settings > Options
dialog box to turn on/off displaying thumbnails and/or 
file information (file name, size, modification date).

If you insert some link *.lnk files linking to some disk 
files and if you later change the location of those target

files, you can specify the new shortcut path globally in 
the Settings > Options dialog.

Right-click or double-click a given object to display the 
context menu and available editing commands and
options.
Clicking the Edit in External Application command 

you can edit the object in the application associated 
with the file type of that object. Changes are saved
automatically after choosing the Save command in that 
application.

Creating new databases
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GS-Base databases are zip archives saved either with the *.zip or *.gsb extensions. The current file 
extension can be changed in the Settings > Options > Default file extension combo box.
The database zip file contain files of the following categories:

1. Database records stored as

[table name].txt

text files. These are plain comma-separated UTF-8 text files containing field names in the first row and 
records in the subsequent rows.

You can edit these files manually without GS-Base using any text editor capable of saving UTF-8 text 
files.
Deleting such a file from the database zip archive means deleting all records.
If you insert any text (*.txt, *.csv, *.tsv, *.tab) file into the zip, GS-Base will detect and report a new 
table(s) and will enable you either to setup and add it to the database structure or to retain it in the zip 
as an unused file.

2. Long Text and Images/Files field subfolders. Each such subfolder has the following form:

[table name].r[8-digit record number]f[5-digit field number] 

For Long Text fields, each such subfolder contains one *.rtf or *.txt file.
For Images/Files fields, each such subfolder contains any number of any files.
You can edit/add/remove these files manually without GS-Base and add/remove/edit subfolders or 

their names.

3. One configuration config.dat file containing various information about the database: the order of 
tables, page settings and formatting.
If you delete this file manually, GS-Base can still use all the record tables and binary fields and re-
import them automatically as if they were new tables.

4. One META-INF/manifest.txt file containing the list of all files used by the database. If the file is 
encrypted, that file also contains various encryption parameters.
If the database is not encrypted, deleting this file doesn't affect the database.
If the database is encrypted, you must not alter that file in any way or you'll risk loosing the data.

5. Any number of any files not used by GS-Base that you can drag-and-drop into the database zip file 

manually.
If the Settings > Options > Show the unused files list option is on, GS-Base will report detecting 
such files. When the database zip file is saved, all such unused files are stored in the separate 
unused/ zip subfolder.

Note: If your database contains a very large numers of memo/image/files objects (e.g. thousands), it's 
recommended to use the *.gsb extension as processing such zip's by Windows (e.g. when performing file

searching/indexing in Windows) might be very slow.

Related Topics

Password protection and encryption
Saving PDF files
Opening and saving text files

Opening and saving html files
Opening and saving Excel XML files

GS-Base zip database file format

GS-Base zip database file format
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The Database Explorer pane enables you to add, delete and update fields as well as re-arrange 
fields and tables, renames them and copy fields between different tables. The respective 

commands are available via the context menu - to display it, right-click that pane.

The drag-and-drop functionality of the explorer tree enables you to change the relative position of 
the database tables and the position of fields within a database table.
Dropping the dragged table over the tree root places that table at the end of the table list.
Dropping a field over the table places that field at the end of the field list.
The drag-and-drop field operation between different tables creates a copy of a given field in the 

target table without copying of the field values from the source table - to copy them, simply copy 
and paste the desirable table data block.

To display the Field Setup dialog box, double click a given field in the Database Explorer pane or 
click that command on the main menu or the context menu (to display it, right-click that field). The 
dialog box offers the following options:

Field name

Any string starting with a letter and containing up to 63 characters.
Field names should be unique within a given table as otherwise formulas referring to record 
fields may produce incorrect results.

Field type

One of the available four field types: "Text", "Numeric", "Long Text" and "Files/Images".
For details, please see: Creating new databases
Changing an existing field type may result in conversion and/or modifying the existing field 
contents.

Special

This value specifies whether the field features some additional functionality. 

� Calculation formula - the specified formula will be used to calculate the current field 
value automatically.
Calculated fields display calculation results only and can not be edited. They are 

updated in the following situations:

� After a given record is modified, all calculated fields within that records are 
updated. 

� After choosing the Tools > Update Data (F9) command, calculated fields of all 
records in the current table are updated. 

Creating links between two tables is a special case of using calculated fields and the
vLookUp_ex function from the Cross-table summarizing & lookup formula 
category. It behaves similarly to the standard spreadsheet vLookUp.

For example, see the included "sample.zip" database and the calculated fields used to 
perform calculation on record fields and to link the "products" and "orders" tables.

Managing database fields and tables

Managing database fields and tables
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For more information about the formula syntax, see: Entering formulas.

� Validation formula - the specified formula will be used to validate data entered in this 
field. The data is accepted if the validation formula returns a numeric value other than

0/false.
For example, if some field ("field_1") should contain only strings at least 4 characters 
long, you can specify the following formula:
=len(field_1) >= 4
For more information about the formula syntax, see: Entering formulas.

� Conversion formula - the specified formula will be used to convert data entered in 

this field.
For example, to ensure that the entered data doesn't contain leading spaces and first 
letters in words are uppercase letters, the following formula can be used:
=proper(trim(field_1))
For more information about the formula syntax, see: Entering formulas.

� Default value - a fixed value that is inserted into selected empty fields after choosing 
the Insert > Default / Incremented Max (Ctrl+T) command.

Also see: Default field values.

� Incremented Maximum - the current (or initial) field maximum value is incremented 

by 1 and inserted into selected empty fields after choosing the Insert > Default / 
Incremented Max (Ctrl+T) command. The field must be numeric or must contain 
date/time values.

Statistics

Calculates the breakdown (field value/number of occurrences) for a given field.
The generated sorted list has a form of plain text so it can be selected and copied on to the 
Clipboard. This and much more advanced functionality is provided by Pivot Tables. 

Formulas

Lists all predefined GS-Base functions that can be used in formula expressions in database 
fields. Database fields are referenced in these expressions by names. 

Managing database fields and tables
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To edit Numeric and Text fields in tables/forms

Do one of the following:

� Press Enter, F2 or any letter/digit key. 

� Double-click a given field. 

You can enter up to 8169 characters in the standard Text fields. Binary (Long Text and 

Images/Files) fields can contain text of any size or any number of objects of any size 
(within the 4GB limit for the 32-bit GS-Base version).

� To complete editing, press Enter or any of the cursor keys or simply click the
table/form. 

� To enter a new line in the edited cell, press Ctrl+Enter. 

� To cancel changes, press Esc. 

For information about entering/editing Unicode characters, please see: Entering Unicode 
characters.

If you set some standard (not using custom patterns) numeric or date/time format for a 
given field, GS-Base will try to interpret the data according to that format.
Fields formatted using custom patterns requires you to enter the data in the default format 
or in one of the standard formats. The date/time style can be applied to Text fields only.

Note: If you want to apply the date format to a text field that already contains some non-

standard (that is, other than YYYY-MM-DD) text strings, you should first use the Edit
>Convert > Text Strings To Date Strings command (or re-enter each date individually). 
This step is required to ensure correct sorting of such a field. 

Trying to edit a Long Text or Images/Files field within a table/form results in the following 
actions: 

1. If the Options > Settings > Table/Form Editing Options > Edit LongText/Files 
fields in new windows option is unchecked, GS-Base will open/hide a new pane 
displaying that data for editing/viewing. 

2. If the Options > Settings > Table/Form Editing Options > Edit LongText/Files 
fields in new windows option is checked, GS-Base will launch an application 
associated with the specified data type (e.g. typically Wordpad for text and Paint for
graphics). Choosing the "Save" command in such an external application will

automatically update the data in GS-Base. 

For the action (2) the following additional functionality is supported:

� Pressing a digit key opens either the text or the n-th (1...9) object for editing in an
external application. 

� Pressing a letter key prints either the text or the n-th (a...z) object in an external 

Editing field contents

Editing field contents
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application. 

To edit Long Text and Images/Files fields

These fields are saved automatically. They feature all the standard functionality such as drag-
and-drop (which includes dropping files/images from other applications) and additional 

commands (e.g. exporting and importing text, formatting and display options) accessible 
through the context menus.

To edit a given memo field or a given image/object in an external application, right click that 
content to display the context menu and choose the Edit In External Application
command. The data will be saved in GS-Base automatically if you use the "Save" command 
in that external application.

If a given binary field is not empty, the respective table or form field contains a single
asterisk (*). If you want to delete the entire Long Text or Images/Files field content at 
once removing the respective entry from the database zip file, simply delete that asterisk.

To move/copy/paste field contents

Tables: Place the mouse cursor over the top edge of the selection and drag it.
You can move the data within the same window, different windows or applications - by 

default GS-Base copies (and provides to other applications) the table data as text and 
bitmaps.
If you drop a file(s) within the table view, GS-Base either pastes the file path if the cursor 
was over a hyperlink field or displays a dialog box enabling you to choose into which 
Images/Files field that file(s) should be inserted. 

Binary Fields: The standard Windows drag-and-drop procedure applies. The dropped objects 
are always copied, not moved. If you want to insert a link into the Images/Files field, press 

and hold down the Ctrl+Shift keys at the same time. 

To fill a given range with some values

1. Copy the value of the selected field or fields. 

2. Select the destination range. The destination range cannot contain more columns than 
the source range. If it does, the additional columns are ignored and won't be filled. 

3. Paste the copied data. 

To use a drop-down list to enter data

Use the Format > List command and specify which list should be used for a given field(s). 

The same list can be shared by any number of fields in any number of tables in one 
database. A database file can contain up to 255 lists. The number of list items is unlimited.
Drop-down list can be static (with values pre-defined by the user) and they can automatically 
add each new unique value entered by the user in the associated field(s). 

Editing field contents
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To use a "Date and Time Picker" control to enter data

The control can be displayed for each text field that (1) is formatted using one of the 
standard "Date" styles (not using custom patterns) and (2) doesn't have any drop-down list 

attached to it at the same time.
Displaying that control can be enabled/disabled in the Settings > Options dialog box. The 
following shortcut keys are used by the date time picker control:

Arrows keys Changes the active control field and/or changes control field values

End and Home
Sets the maximum and minimum values for the current part of the date (a 

year, month or day)

Plus and Minus
Increments/decrements the current part of the date (a year, month or 
day)

Alt+Down
Displays the "Month Calendar" control. Same as clicking the "drop-down"
arrow

PageUp, 
PageDown

If the "Month Calendar" control is active, moves to the previous/next
month

Editing field contents
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Unicode characters can be edited/entered using the following methods:

1. Enter a sequence of 1-6 hexadecimal digits and immediately press 

Alt+X. Note that any preceding and not separated valid hexadecimal 
digits will be converted as well. This method can be used only when 

editing fields; it's not available in dialog boxes. 

2. Press Ctrl+Shift+U then enter a sequence of 1-6 hexadecimal digits 

and immediately press Space. 

3. Press and hold down Alt, then on the numeric pad press + and a 

desirable hexadecimal code, then release Alt. This method may require 

adding the following key in the Windows registry:

HKEY_CURRENT_USER/Control Panel/Input Method/EnableHexNumpad
The value of the above key should be set to "1" (entered as REG_SZ). 

Entering Unicode characters

Entering Unicode characters
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To enter/edit a formula

Formulas available in GS-Base are similar to those used in spreadsheets with a few 
exceptions: 

� Cell references are replaced by field names. All field names occurring in a given formula 
refer to one and the same record. 

� The range ":" operator is not available. Formulas requiring array/range parameters can 
use the "array()" function that creates an array out of database fields, strings, numbers 

etc. 
� References to other tables via the "!" and "_" operators are not available. Instead, 

there is a separate category of functions: Cross-table summarizing & lookup
functions that groups functions accessing data from other database tables in the same 
database. Some of those functions can be used to create links/relations between 

tables. (See the included "sample.zip" database and its calculated fields used to link the 
"products" and "orders" tables.)

For example, to sum up two fields 'subtotal' and 'tax', use the following formula:

=subtotal + tax 

to merge two fields 'name' and 'country', use the following formula:

=name & ", " & country

and to obtain a period string representing the difference between two given dates:

=dateDiff("2011-01-01", "2011-12-31")   (which returns "P364D") 

A few other examples:

=Unit_Price*Qty
="abc"
=1 + 2
="a" & 'b' & 3

=fv(0.75%, 36, -500, -5500, 0)
=LProg({2,2;1,2;4,0}, {1;1;1}, {14;8;16}, {2; 4},0,,)
=sum(field1, field2, field3, sum(field4, field5, field6))

Numbers and dates used as arguments cannot be formatted. For example, the following 
expressions are incorrect:
=$1,000.00 + 1 , =dateDiff("6/3/11", "8/9/2011").
Text strings should be delimited either by single or double quotation marks.

Formulas should not contain circular field references.

To browse all available formula categories and examples, please see the Field Setup dialog 
box or the Search dialog box.

Entering formulas

Entering formulas
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Note: Square brackets [,] in parameter lists denote parameters that are optional and can be 

omitted. For example:

LProg(A, s, b, c, vector, [epsilon], [m])

However, you still have to use the corresponding parameter list separators, that is:

LProg(A, s, b, c, vector,,) 

If your current Windows regional settings define commas as decimal separators, use 
semicolons (;) to separate function arguments or - if you prefer to use system independent 
(US) settings - select the generic locales via the Settings > Locales > Generic command.

Available operators:

Operator Operation Comments Precedence

= Equal Compares numbers or text strings (the 

comparison is not case-sensitive).
Example: A1=4 , B2="abc"

6

< Less than Compares numbers or text strings (the 
comparison is not case-sensitive).
Example: A1<4 , B2<"abc"

6

> Greater than Compares numbers or text strings (the 
comparison is not case-sensitive).
Example: A1>4 , B2>"abc"

6

<= Less than or equal Compares numbers or text strings (the 
comparison is not case-sensitive).

Example: A1<=4 , B2<="abc"

6

>= Greater than or 
equal

Compares numbers or text strings (the 
comparison is not case-sensitive).
Example: A1>=4 , B2>="abc"

6

<> Not equal Compares numbers or text strings (the 

comparison is not case-sensitive).
Example: A1<>4 , B2<>"abc"

6

+ Addition Adds numbers. 5

- Subtraction 5

& String 

concatenation

Merges text strings.

Example: A1 & "abc" , "a" & "b"

5

* Multiplication Multiplies numbers. 4

/ Division Divides numbers. 4

^ To the power of Calculates the power of. 3

- Negative Example: -A1 2

% Percent Specifies a number entered as a percentage.
Example: 12%

1

Entering formulas
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Pivot tables enable you to quickly and easily obtain and visualize various statistical information about the data stored 

in flat source record tables. This includes (but is not limited to) counting, summarizing, sorting or finding partial 

maximum/minimum and mean values. 

In GS-Base you can create up to 100 pivot tables for each database table. To create a new pivot table, use the View 

> Pivot Table View command and in the opened pivot table pane click Pivot Table > Add New Pivot Table or - if 

this is the first pivot table - simply click the Setup button.

Quick start

Open the included sample "sample.zip" database and choose the "customers" table.

The records contain (among others) the "Country" and "City" fields.

To obtain the number of customers from particular countries:

1. Open the Pivot Table Setup dialog. 

2. Choose the "Country" database field as the only Row field. 

3. click OK. 

To obtain the number of customers from particular countries and to find out how many of them come from given 

cities in that country:

1. Open the Pivot Table Setup dialog. 

2. Choose the "Country" database field as the first Row field. 

3. Choose the "City" database field as the second Row field. 

4. click OK. 

Using Pivot Tables
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Open the included sample "sample.zip" database and choose the "orders" table.

The records contain (among others) the "ProductName" and (order) "Date" fields.

To obtain the numbers of sold products and to find out how these numbers looked like in subsequent days:

1. Open the Pivot Table Setup dialog. 

2. Choose the "ProductName" database field as the only Row field. 

3. Choose the "Date" database field as the only Column field.

4. click OK. 

To obtain the numbers of sold products and to find out how both these numbers and the sales totals looked like 

in subsequent days:

1. Open the Pivot Table Setup dialog. 

2. Choose the "ProductName" database field as the only Row field. 

3. Choose the "Date" database field as the only Column field.

4. Choose the "Total" database field as the first Data field and select the Count function for it.

5. Choose the "Qty" database field as the second Data field and select the Sum function for it.

6. click OK. 

Using Pivot Tables
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To specify a default value for a given Text/Numeric field

Open the Field Setup dialog box (double-clicking that field in the Database Explorer window 
or using the Field Setup command), select the Special > Default value option and enter 
the desirable value which can be:

� For numeric fields: any unformatted number. 
� For text fields: any text string.

If that text field is formatted as "Date", the default value should represent the generic 

date/time string: YYYY-MM-DD.

To insert the default field value

Select a range of fields and/or records and use the Insert > Default Value (Ctrl+T)

command. Default values are inserted into all empty fields within that selection.

Default field values

Default field values
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To select a range of fields and/or records in the table view

Do one of the following:

� Use the mouse cursor. 

� Press Shift and use any of the scrolling keys. 

� Press Ctrl+Space to select the current field in all records

� Press Shirt+Space to select the entire current record 

To jump to the desirable record or to select a record range

Click the Record field on the bottom toolbar or press Ctrl+G, then enter the record number 

or a record range (as two numbers separated by ":") and press Enter.
You can also use menus attached to the "Previous"/"Next" buttons to scroll up or down by
one record or to some specific record: 

� Top / bottom 

� Previous / next non-empty field 

� Previous / next empty field 

� Previous / next identical field value 

� Previous / next different field value

Navigation / shortcuts keys

Other shortcuts

Selecting fields and records, scrolling, shortcut keys

Up, Down, Left, Right scroll by one row/column

Ctrl+Up, Ctrl+Down Go up or down to the next empty field

Alt+Ctrl+Up, Alt+Ctrl+Down Go up or down to the next field with the same content

PgUp, PgDn, Alt+PgUp,
Alt+PgDn

scroll by one page vertically or horizontally

End last non-empty column

Home first column

Ctrl+End last non-empty row

Ctrl+Home first row

Ctrl+PgUp
previous table (in the print-preview mode: previous 
page)

Ctrl+PgDn next table (in the print-preview mode: next page)

Selecting fields and records, scrolling, shortcut keys
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To use the 'auto-scroll' function

Click the worksheet window using the mouse wheel button and choose the desirable scrolling
speed and direction by moving the mouse cursor around the clicked point.

Ctrl+B bold font

Ctrl+I italic font

Ctrl+U underline font

Ctrl+K strikeout font

F6 next pane 

Shift+F6 previous pane 

Selecting fields and records, scrolling, shortcut keys
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Fonts

The Font dialog box enables you to specify all basic font attributes including its name, size, 
weight, slant (the italic style), the underline and strikeout options and the font color. 

To revert to the default settings, click the Reset button. 

Style

You can use the following standard numeric styles and their options:

� Default
(No specific formatting. Numbers with more than 15 digits are displayed in the
exponential-scientific format.) 

� General 

� decimal places (0 to 14)

� leading zeros (0 to 14) 

� thousand separator 

� displaying negative numbers in red or in parenthesis 

� Currency 

� currency symbol position 

� currency symbol 

� displaying negative numbers in red or in parenthesis 

� Accounting 

� currency symbol

� Date 

� date pattern 

� using fixed or system dependent year/month/day order 

� Time

� time/period pattern

� Date/Time

� date pattern 

� time pattern 

� using fixed or system dependent year/month/day order 

� date/time order

� Percent

Formatting

Formatting
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� decimal places (0 to 14)

� Fraction

� either a fixed denominator value (1 to 9,223,372,036,854,775,807) or a fixed 
number of denominator digits (1 to 19)

� Scientific

� decimal places (0 to 14) 

� a fixed exponent value 

Alternatively, you can use a user-defined numeric format. To do this, simply enter the

desirable style pattern in the Style dialog box. If you need to re-use it, you can save it as a 
new user style with a new name. To learn more about style patterns, please see how the 
standard styles are defined. For example, the accounting format is defined as: 

_(\$* #,##0.00_);"($"* #,##0.00\);_(\$* \-??_);_(@_) 

and the fraction format with the fixed denominator (4) can be defined as: 

?\ ?/\4

User-defined formats allow you to specify font colors for numbers that meet some conditions. 

For example:

[green]#.#;[red]\-#.#;[blue]#.#;[gray]@ 

displays positive numbers in a green font, negative numbers in red, blue zeroes and gray 

text labels,

[red][<10]#0.00;[yellow][<=50]#0.0;[green][<400]##0;[magenta][>=400]#00

displays numbers less than 10 in a red font, numbers less or equal to 50 in a yellow font, 

numbers less than 400 in a green font and numbers greater or equal to 400 using a magenta 
font. 

Color values can be expressed as RGB values (for example, [red][<10]#0.00 is the same as 
[#FF0000][<10]#0.00) or by one of the following color names: 

black [#000000] maroon [#800000]

green [#008000] olive [#808000]

navy [#000080] purple [#800080]

teal [#008080] gray [#808080]

silver [#C0C0C0] red [#FF0000]

lime [#00FF00] yellow; [#FFFF00]

Formatting
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Alignment

The Alignment dialog box enables you to specify the following options: 

� how to display text strings that exceed the cell width, 

� horizontal and vertical indents (the distance measured from the cell contents to the cell 
boundaries), 

� text rotation, 

� horizontal (left, center, right) and vertical (top, center, bottom) alignment;
unformatted cells display vertically centered, right-aligned numbers and vertically 
centered, left-aligned text strings. 

To revert to the default settings, click the Reset button. 

Hyperlink

Treats the field contents as a hyperlink. Clicking that field opens the link. The link can be a 
www address, e-mail address or a regular file on your local disk.
You can explicitly specify the link type/protocol adding one of the following prefixes:

� http:// 

� https:// 

� file:// 

� mailto:

� ftp:// 

� gopher:// 

� nntp:// 

� news:// 

� wais:// 

� telnet://

� prospero:// 

� res:// 

Drop-down lists

You can use the Drop-down list dialog box to set the drop-down list format and/or to manage 
(create, edit, delete) lists in the current workbook. 

blue [#0000FF] fuchsia [#FF00FF]

aqua [#00FFFF] white [#FFFFFF]
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When editing a field with some drop-down list attached to it, you can quickly choose some 

predefined cell value instead of re-typing it.
To set that format, simply choose an existing list or click the New List button. 

To add list items, enter them in the List Items edit field: one item in one line.

If you choose the Append new items option, each unique value entered in the 
corresponding field(s) will be added to the list automatically.
If the Sort items option is not selected, the list will display all its elements in the same order 
as they were added/entered. 

One list can be used by any number of fields in any table. You may create up to 100 list in 
one database file. To move lists between files, you have to copy/paste the data from the List 
Items edit field. 

Formatting
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To set/modify a field filter

Scroll to a given field and press Ctrl+F or Ctrl+Enter or click the Search button or use the 
Tools > Set Search Filter command.

Filters specified for more than one field at the same are assumed to be merged by the AND 
logical operator and narrow down the search results.

� The displayed Search dialog box enables you to specify the filter and its type.
To search for the currently selected field value, click the "=" button or press Ctrl + =. 

� The default filter type for text fields is Regular Expression and for numeric fields: 

Equal. 

� After a given filter type is used for some field, it becomes its default type. 

� The default initial filter type can be changed in the Settings > Options dialog box.

� Allow empty matches and Match case are two options used by the Regular
Expression filter type only.

Empty matches occur for Regular Expression like \A\z or a? . 

There are three filter types available for numeric and text fields:

1. Regular Expressions (RegEx) - the filter string is a data pattern based on standard 
regular expression syntax. Some examples of regular expressions:

abc - matches substrings "abc",

.bc - matches three character substrings consisting of any character followed by "bc",

\Aabc - matches field contents starting with "abc",

abc\z - matches field contents ending with "abc",

\Aabc.*123\z - matches field contents starting with "abc" and ending with "123" with 
any number of other characters in between,

abc\d\z - matches substrings ending with "abc" and one digit,

^a\d+ - matches field contents containing a line starting with "a" and at least one digit,

^a\d* - matches field contents containing a line starting with "a" and zero or more 
digits,

[ab]+c - matches substrings "abc", "aabc", "abbabc" etc. and not "c",

[ab]*c - matches substrings "abc", "aabc", "abbabc" etc. and "c",

[^ab]+c - matches substrings ending with "c" and not containing "a" or "b",

\w\d{2,3} - matches substrings consisting of one letter followed by 2 or 3 digits,

\Aab\d{2,3}c - matches field contents beginning with "ab", two or three digits and "c",

abc|xyz - matches substrings "abc" or "xyz",

\A\z - matches empty fields,

For more information, see PCRE regular expression syntax summary

2. Plain text (Starts with, Equal, Not equal, ...) - the filter string represents a plain 
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text string that is compared against the whole field contents. This filter category 

includes a few variants: "Pattern", "Equal", "Not equal", "Greater than", "Less than",
"Between", "And" and "Or".
For the "Starts with", "And" and "Or" variants the filter string can be a prefix of the 
compared strings and can contain wildcard "?" and "*" characters. Any non-wildcard "?" 
and "*" characters must be prefixed with a tilde (~).

The remaining variants perform exact text string comparisons. For "Between", "And" 
and "Or" the entered filter must be a list of respectively two or more elements 
separated by spaces.
Examples:

abc - matches field contents beginning with "abc" ("Starts with"),

?bc - matches field contents beginning with any character followed by "bc" ("Starts 
with"),

*abc - matches field contents ending with any character followed by "abc" ("Starts 
with"),

* - matches all non-empty field contents ("Starts with"),

50.1 100.2 - matches values equal to or between 50.1 and 100.2 ("Between", US 
regional numeric settings),

12/1/2012 12/31/2012 - matches dates equal to or between the specified ones 
("Between", US regional date settings),

ab cd *ef - matches field contents equal to "ab", "cd" or ending with "ef" ("Or")

3. Formulas - the filter string represents a formula expression that can make use of the 
all the built-in functions, operators and references to other record fields. The formulas 
are similar to those used in spreadsheets with a few exceptions:

cell references are replaced by field names,

the range ":" operator is not available,

direct references to other tables via the "!" and "_" operators are not available.

When searching, such a formula is evaluated for each record and a given record is 
considered to meet the searching criteria if each the formula returns a non-zero value.

To learn more about building formulas, see: Entering formulas

Long Text or Images/Files fields always use Regular Expressions to filter records. When
filtering Images/Files fields, the file names are searched.

To remove all specified search filters, click the (None) search key on the toolbar or use the 
Tools > Reset Searching command.

To filter records and search for duplicated field values

Scroll to a field or select a range fields which should be searched and use the Tools > Find 
Duplicates command.
To find entire duplicated records, select an entire row clicking the row heading or pressing 

Shift+Space.
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To filter records and search for flagged records

Use one of the Tools > Find Flagged Records commands.
By default, when installing GS-Base creates only one "Highlighted" flag type that causes 

displaying a record in red. You can define up to 10 flag types for each database using the 
Tools > Record Flags command.

To filter records and display the complement of the current record set

To find the complement of the current record set (that is, all the records that are not included 
in the current record set), use the Tools > Find Complement command.

To perform full-text searches and search for patterns occurring in any text and numeric 
fields

Use the Edit > Find (F3) command and in the displayed Search Toolbar enter the 
desirable substring. The Find Previous/Next commands simply scroll to the subsequent 
found table or form cell values. The Find All command performs full-text filtering of Text
and Numeric fields (Long Text fields are not included).

The search toolbar also enables you to replace found substrings. If you want to perform 
such a find-and-replace action for one field only, select the column clicking its header.

Searching
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To perform full-text searching use the Edit > Find (F3) command and in the Find field of the 
displayed Find & Replace toolbar enter the data pattern or plain substring to look for.

The Find Previous/Next commands simply scroll to the subsequent found table or form cell 

values. The Find All command performs full-text filtering of Text and Numeric fields (Long Text
fields are not included).

Depending on which view is currently active (a table, form or a memo/object field), the searching 
procedure can concern:

� all numeric and text fields of all records contained by the (optionally filtered) table 

� all numeric and text fields of the record displayed on the form 

� the current memo field 

There are three search modes that can be specified using the Options button menu:

� Regular Expressions - the Find string is a data pattern based on standard regular 

expression syntax. Some examples of regular expressions:

abc - matches substrings "abc",

.bc - matches three character substrings consisting of any character followed by "bc",

\Aabc - matches field contents starting with "abc",

abc\z - matches field contents ending with "abc",

\Aabc.*123\z - matches field contents starting with "abc" and ending with "123" with any 
number of other characters in between,

abc\d\z - matches substrings ending with "abc" and one digit,

^a\d+ - matches field contents containing a line starting with "a" and at least one digit,

^a\d* - matches field contents containing a line starting with "a" and zero or more digits,

[ab]+c - matches substrings "abc", "aabc", "abbabc" etc. and not "c",

[ab]*c - matches substrings "abc", "aabc", "abbabc" etc. and "c",

[^ab]+c - matches substrings ending with "c" and not containing "a" or "b",

\w\d{2,3} - matches substrings consisting of one letter followed by 2 or 3 digits,

\Aab\d{2,3}c - matches field contents beginning with "ab", two or three digits and "c",

abc|xyz - matches substrings "abc" and "xyz",

\A\z - matches empty fields,

For more information, see PCRE regular expression syntax summary

The Replace string can contain:
(1) absolute references (by number) to capturing subpatterns, eg. \1, \2...

a capturing subpattern (or a "group") is a part of the pattern enclosed in () parenthesis. (2) 
\l, \L, \u, \U literals to (binary) switch upper- and lower-case conversion
(3) \r, \n - 'line feed' and 'new line' literals (by default, Ctrl+Enter inserts the \r\n sequence 
into the text field).

Full Text Searches and Replacing
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(4) \s - a single space character.

Example 1.

Example 2.

Example 3.

Example 4.

� Plain Text - Partial Matching - the Find string represents a plain text string that is 

compared against the beginning of the field contents. The string can contain wildcard "?" and 
"*" characters. Any non-wildcard "?" and "*" characters must be prefixed with a tilde (~). 

� Plain Text - Full Content Matching - the Find string represents a plain text string that is 

compared against the whole field content. The string can contain wildcard "?" and "*" 
characters. Any non-wildcard "?" and "*" characters must be prefixed with a tilde (~).

If the full text searching is performed for a single memo field data, the search mode automatically 
defaults to the Plain Text - Partial Matching search mode.

Find pattern: ab+

Database field content: abcdefaabb

Replace string: x

Replacement result: xcdefax

Find pattern: (.)a+\d{1,3}

Database field content: abc aa0102

Replace string: \1

Replacement result: abc 2

Find pattern: (ab)

Database field content: abcdef ghijk abb123

Replace string: \u\1\l\1xyz\s

Replacement result: ABabxyz cdef ghijk ABabxyz b123

Find pattern: \R

Database field content:
abc
def

ghi

Replace string: \s

Replacement result: abc def ghi
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To sort records

Click the Sort toolbar button. If you want to define a multi-field sort key, press and hold 
down the Shift key.

To specify more complex sort keys and to change the default comparison functions, use the
Tools > Sort command.

When sorting Long Text or Images/Files fields, GS-Base compares the total size of the 
field contents.

Note: Objects inserted as links (shortcuts) to external files (with the Insert Shortcut to...
command) will be sorted by size if they were inserted in GS-Base ver. 12.1.3 or later. Unless
re-inserted, earlier links will be treated as 1-byte objects.

Sorting
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To print tables, forms, letters or labels

In the Print dialog box, choose the desirable print mode clicking one of the tabs: Table, 
Form, Letter, Labels.

Depending on your selection, you will be able to specify several additional printing options for
each print mode.

Table:
This is the default print mode. Use it to print selected records in plain tables.

Note that neither Long Text nor Image/File are printed in that mode.
To specify which other fields should be printed, click the Table tab.

Form:
GS-Base will print each record as a fixed-layout form. There are two form variants:
(1) one-page forms where the first Long Text or Image/File and the remaining 
Text/Numeric fields are printed "side by side" on a single page,

(2) multi-page forms where all Long Text or Image/File fields are printed on the 
subsequent pages after all Text/Numeric fields, one field per page.
To specify which field should be printed and to turn on/off printing one-page forms, click the 
Form tab.

Letter:
GS-Base will print a user-defined *.rtf form containing any amount of text and graphics with 
embedded references to text and numeric record fields and with embedded formulas 

performing calculations. A field reference is specified by a field name in double-curly braces. 
A formula additionally must begin with "=".
One copy of such a document is printed for each record of the current record set.
Clicking the Edit in External Application command you can edit the form in the application 
associated with the *.rtf format. Changes are saved automatically after choosing the Save

command in that application. 

Labels:

You must define the required label format. To do this, click the Labels tab, then click the 
New Labels button and enter the name of your new label format.
Then specify the number of columns and rows of labels on one page, vertical and horizontal 
label spacing and insert data fields you want to print on each label.
Data fields can be simple database field names (references) or formulas (see: Entering 

formulas).
If the resulting text overflows the field rectangle:

� data entered as formulas is always wrapped and 

� data entered as plain database field references is either wrapped or truncated, 
depending on the current format of that field.

If you want the formula data to span two or more lines, insert the char(13) or char(10) (new 
line/line feed) functions between field values and/or strings in that formula, for example: 
=Name & char(13) & City .
When editing labels you can move or resize the fields. To select a group of fields press Shift

Printing tables, forms and labels
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and click subsequent fields or press down the left mouse button and drag the mouse cursor.

To set the default height of the data field rectangle, right-click it.
To rename an existing label format, press Shift and click New Labels button.

Select the desirable Page Range option. You can print all found records, selected range of 
records or particular pages.

To print selected pages

Choose the Pages option in the Print > General dialog box and specify the list of pages to
print.
The list can contain single pages or page ranges separated by commas. For example: 1,2,4-
8,10

To print more than one page on a single paper sheet

Specify the number of printed pages in the Pages per sheet fields in the Print > Layout
dialog box. For example, if you choose two columns and three rows, one sheet will contain 
(up to) six pages.

To include a table name, page number, date etc. in the printed pages headers and footers

In the Print > Layout dialog box, enter the header/footer text inserting the following special
codes:

To format the header/footer text

In the Print > Layout dialog box, enter the header/footer text inserting the following special 
codes:

&p Prints the current page number

&p+number Prints the current page number plus 'number'

&p-number Prints the current page number minus 'number'

&n Prints the total number of pages

&m Prints the current paper sheet number (different than &p when printing many 
pages on one sheet)

&f Prints the full file path

&a Prints the name of the printed table

&d Prints the current date

&t Prints the current time

&g Prints the file modification date

&z Prints the file modification time

&& Prints a single ampersand

Printing tables, forms, letters and labels
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To change the view scale in the print-preview window

Click the Zoom In button and pressing the right mouse button select a rectangle that should 
be zoom in.

&l Left-aligns the following text

&c Centers the following text

&r Right-aligns the following text

Printing tables, forms, letters and labels
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To password-protect and encrypt the data in the database zip file, use the File > Protect

command and specify a password consisting of at least 6 characters.

To encrypt the data, GS-Base currently uses the Twofish CFB algorithm. All encryption parameters 

are saved in the META-INF/manifest.txt text stream in the database zip file.

If the database zip file is encrypted and you still want to manipulate some its data manually 

without GS-Base, using Windows Explorer, you must not alter the META-INF/manifest.txt file in 
any way or you'll risk loosing the data.

Files added by users manually to the zip that are not used/imported by GS-Base remain 
unencrypted and are moved to the "unused/" zip subfolder.

If a database is encrypted and protected, there is a green shield symbol displayed on the status 

bar.

Password protection and encryption
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To save data in the PDF format:

� Use the File > Save Table As PDF and File > Save All Tables As PDF commands.
The former saves the current table and the latter - all tables of the database. You can change 
the page layout and other content options using the File > Page Settings command. 

Note: When saving a PDF file GS-Base maps all fonts used in a workbook to the standard set of 14 
PostScript Type 1 fonts which are required to be present in every PDF viewing application and in 
every operating system.

To specify the advanced PDF save options, use the File > Advanced PDF Save Options command. 
GS-Base enables you to choose the language/code page that should be used when saving the current
record set to a PDF file and to specify the custom character encoding list to correctly display all 
glyphs for that language.
If you don't choose any language before saving, GS-Base will use the default Windows system ANSI 

code page when converting the Unicode text to the ANSI text required by the PDF format.

For example, the encoding list for the iso-8859-1 code page can be:

32 /space /exclam /quotedbl /numbersign /dollar /percent /ampersand /quotesingle
/parenleft /parenright /asterisk /plus /comma /hyphen /period /slash /zero /one
/two /three /four /five /six /seven /eight /nine /colon /semicolon /less /equal
/greater /question /at /A /B /C /D /E /F /G /H /I /J /K /L /M /N /O /P /Q /R /S

/T /U /V /W /X /Y /Z /bracketleft /backslash /bracketright /asciicircum /underscore
/grave /a /b /c /d /e /f /g /h /i /j /k /l /m /n /o /p /q /r /s /t /u /v /w /x /y /z
/braceleft /bar /braceright /asciitilde /bullet /Euro /bullet /quotesinglbase /florin
/quotedblbase /ellipsis /dagger /daggerdbl /circumflex /perthousand /Scaron

/guilsinglleft /OE /bullet /Zcaron /bullet /bullet /quoteleft /quoteright /quotedblleft
/quotedblright /bullet /endash /emdash /tilde /trademark /scaron /guilsinglright
/oe /bullet /zcaron /Ydieresis /space /exclamdown /cent /sterling /currency /yen
/brokenbar /section /dieresis /copyright /ordfeminine /guillemotleft /logicalnot

/hyphen /registered /uni203E /degree /plusminus /twosuperior /threesuperior
/acute /mu /paragraph /periodcentered /cedilla /onesuperior /ordmasculine
/guillemotright /onequarter /onehalf /threequarters /questiondown /Agrave /Aacute
/Acircumflex /Atilde /Adieresis /Aring /AE /Ccedilla /Egrave /Eacute /Ecircumflex
/Edieresis /Igrave /Iacute /Icircumflex /Idieresis /Eth /Ntilde /Ograve /Oacute

/Ocircumflex /Otilde /Odieresis /multiply /Oslash /Ugrave /Uacute /Ucircumflex
/Udieresis /Yacute /Thorn /germandbls /agrave /aacute /acircumflex /atilde /adieresis
/aring /ae /ccedilla /egrave /eacute /ecircumflex /edieresis /igrave /iacute
/icircumflex /idieresis /eth /ntilde /ograve /oacute /ocircumflex /otilde /odieresis

/divide /oslash /ugrave /uacute /ucircumflex /udieresis /yacute /thorn /ydieresis

The encoding list the Windows-1250 code page could be:

32/space 40/parenleft/parenright 44/comma/hyphen/period/slash/zero/one/two/three/four
/five/six/seven/eight/nine/colon 65/A/B/C/D/E/F/G/H/I/J/K/L/M/N/O/P 82/R/S/T/U
87/W/X/Y/Z 97/a 99/c/d/e/f/g/h/i/j/k/l/m/n/o/p 114/r/s/t/u 119/w 121/y/z 140/Sacute
143 /Zacute 156/sacute 159/zacute 163/Lslash 165/Aogonek 175/Zdotaccent 179/lslash

185/aogonek 191/zdotaccent 202/Eogonek 198/Cacute 209/Nacute 211/Oacute
230/cacute 234/eogonek 241/nacute 243/oacute 

Saving files: PDF files
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To open a text file

Use the File > Open command and choose Text from the File of type list or drag and drop 
a given text file into the main GS-Base window.

Next, specify additional text file options:

Opening and saving text files

Field separator A single character used to separate fields in one line.

Fixed field widths A list of fixed field width values. For example:
10,30,15,40
If not all widths are specified, the remaining fields are assumed 
to contain 1024 characters.

Quoting symbol A symbol used to delimit fields containing separator characters.

Fields that contain quoting symbols must be delimited by quoting 
symbols as well. The inner marks must be doubled in such a 
case. For example, if some row contains the following four 
values/fields:

a,b
c
d

="a" & "1"

they will be saved as

(1)  a,b|c|d|=""a"" & ""1""

(2)  "a,b",c,d,"=""a"" & ""1"""
(3)  a,b;c;d;"=""a"" & ""1""" 

where the double quotation mark (") is the quoting symbol and 
the separators are respectively:
(1)  |
(2)  ,
(3)  ;

Encoding Specifies the text encoding for a given text file: UTF-8, UTF-16, 
ANSI 8-bit, ISO/OEM. The initial value is set based on the file
initial bytes. 

First row contains 
field names

Specifies whether text strings from the first line of the file should 
be treated as field names. If you clear this option when reading 

a text file, GS-Base will use simple "field_nnnn" names. A field 
names must begin with a letter. 

Convert data to 
numeric fields 
wherever possible

If you check this option, a column containing only text strings 
that can be converted to numbers (without formatting) will be 
treated as a numeric database field. Otherwise all such columns 

will be imported as text fields (and will be sorted and searched 
as plain text fields).
You can also change the field type after you import the file using 

Opening and saving text files
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To save a text file

Use the File > Save Recordset As command and choose Text from the File of type list. 
Next, specify the same additional text file options as above.

Note: When saving a text file, GS-Base saves only filtered records from the active table.

Related Topics

Saving PDF files
Opening and saving html files
Opening and saving xBase files

Opening and saving Excel XML files

the Database > Field Properties command. 

Opening and saving text files
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To open a html file

Use the File > Open command and choose HTML from the File of type list. Next, specify 
which table you want to load.

To save records to a html file

Use the File > Save Recordset As command and choose HTML from the File of type list. 
Next, specify additional html file options:

Related Topics

Opening and saving text files
Opening and saving xBase files
Opening and saving Excel XML files

Opening and saving html files

Template Specifies an optional HTML file that should be used as a template. 
The file must contain a TABLE element with the ID attribute set to 

'gsbase', e.g.

<TABLE id="gsbase"> ...

GS-Base will empty that table and fill it with the specified records. 
All attributes of the TR, TH and TD tags are removed; you should 

specify column formatting using the COLGROUP and COL tags 
instead.

If you don't provide any template, GS-Base will create and save a 
basic/minimal HTML document containing a table filled with
records.

Note that Image/File fields are not saved.

Saved fields Specifies which fields should be saved.

Save duplicated 

field values as

Specifies a text string that should be used to replace the same

values occurring in the same field and subsequent records.

Encoding Specifies text encoding. Currently the only valid value is UTF-8.

First row contains 
field names

If you check this, the first row of the saved table will contain field 
names as TH elements. 

Opening and saving html files
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To open an xBase file

Use the File > Open command and choose dBaseIII, dBaseIV, FoxPro 2.x or Clipper
from the File of type list or drag and drop a given xBase file into the main GS-Base window.

Next, specify additional xBase file options:

dBase/FoxPro/Clipper records marked as "deleted" are displayed with the "Selected" flag (the 
default "0" flag for each GS-Base database).

To save an xBase file

Use the File > Save Recordset As command and choose dBaseIII, dBaseIV, FoxPro 2.x 
or Clipper from the File of type list.

Note: When saving an xBase file, GS-Base saves only filtered records from the active table. 
To save all existing records you should remove filters e.g. clicking the Show All toolbar 

button (or the corresponding Tools > Show All Records command).

Records marked with the the "Selected" flag (the default "0" flag for each GS-Base database) 
will be saved to dBase/FoxPro/Clipper databases as "deleted" records.

Related Topics

Saving PDF files

Opening and saving text files
Opening and saving html files
Opening and saving Excel XML files

Opening and saving dBase/FoxPro/Clipper files

Encoding Specifies the text encoding for a given xBase file: ANSI 8-bit or ISO/OEM.

Opening and saving dBase/FoxPro/Clipper files
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To open an Excel 2003 XML file

Use the File > Open command and choose the Excel XML format from the File of type list 
or drag and drop a given xml file into the main GS-Base window.

To save an Excel 2003 XML file

Use the File > Save Recordset As command and choose the Excel XML format from the 
File of type list.

Notes:

� When saving an Excel XML file, GS-Base saves only filtered records from the active 
table.

� When saving memo fields, GS-Base saves the first 32KB of each field. When opening 

an Excel XML file, fields longer than the maximum standard field width (1024 
characters) are truncated. 

Related Topics

Saving PDF files
Opening and saving text files
Opening and saving html files
Opening and saving xBase files

Opening and saving Excel XML files
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All GS-Base global settings are stored in the settings.xml files. Their location 
depends on how you install the application. If you choose the portable 

installation, the settings file will be saved directly to the installation folder. 

Otherwise they're store in the local application data folder (e.g. 
C:\Users\username\AppData\Local\GS-Base).

You can use the Settings > Save - Load Profile commands to save or load

different settings profile files.

The following data can be specified in the Settings > Options dialog: 

General Settings

Undo/Redo level

The number of actions that can be undone via the Edit > Undo-

Redo commands.

A very high undo level causes greater memory usage if some 
very large copy/paste operations are performed.

The drag-and-drop operation is treated as a two-step action so 

the minimum undo level is 2.

Valid range: <2, 200>
Default: 20

Used processor cores (threads)

The number of processor cores that GS-Base is allowed to use 
when updating calculated fields (Tools > Update All Calculated 

Fields) and when filtering records (excluding full-text searches in 

memo fields).

Valid range: <1, 10>
Default: 2

Default text field filter

Specifies the default filter type for text fields. This filter type will 
be initially set in the Search dialog box.

Default: Regular Expression

Settings
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Default pivot function

Specifies a function that will be used by each new or existing
pivot table that doesn't have any data field defined.

The default count function results in counting all subsequent 

values of the specified row field(s).

Default: Count

AutoSave

Specifies the period of (user) inactivity after which GS-Base will 

automatically save the open database (if it's modified).
Default: Never

AutoClose

Specifies the period of (user) inactivity after which GS-Base will 
automatically close the open database. Modified databases are 

saved before closing.

Default: Never

After pressing Enter

Specifies whether (and how) to scroll the current table cell after 

you finish editing and press Enter.
Default: No action

Default file extension

Specifies the primary file extension (either *.zip or *.gsb) for the 
GS-Base native file format. GS-Base uses that extension when 

creating and saving new files.

Choosing "*.gsb" causes GS-Base file type registration in 

Windows so you can later double-click a given *.gsb file to launch 
GS-Base.

Switching over back to the "*.zip" extension removes all

registration keys from Windows registry.

Default: *.zip
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Start folder

Specifies the folder displayed in the Open File dialog box when 
you open it for the first time (after launching GS-Base).

Default: Empty

Relative shortcut path

If you insert some link *.lnk files into Images/Files fields and 

later change the location of the target objects that the links are 

connected to, you can "overwrite" such broken links globally 

specifying that path.
Default: Empty

No-deflate file types

Specifies the list of file types (stored in Images/Files fields) that 
will be saved in the database zip file without compression. The 

list should contain file types that contain already compressed 

data. This can improve loading/saving times without worsening
the overall compression factor.

Enter the extensions in the *.ext1;*.ext2;... form.

Default: *.png;*.jpg;*.gif;*.pdf;*.zip;*.ods

Show unused zip file list

If you manually drag-and-drop any files to a given database zip 

file, GS-Base will detect such files and show the list of them.

If the option is off, GS-Base will silently load and save back such
unused files.

Default: On

Show progress when opening/saving files

If this option is checked, GS-Base will be displaying a progress 

dialog box when opening or saving all files. The progress dialog 

box contains information about the opening/saving process and 

enables your to cancel it at any time.
Default: On
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Windows opacity

Specifies the opacity of all dialog boxes displayed by GS-Base. 
Decreasing this value means making the windows more

transparent.

Valid range: <10, 100>

Default: 100% (no transparency)

Default font

Specifies the default font name. The font specified here will be 

used by database tables, forms, binary edit windows and pivot 
tables.

Default: Arial

Table/Form Editing Settings

Use date time picker when editing dates

Check this option to use the date-time picker control instead of 
the plain edit control.

This options applies to text fields that are formatted using one of 

the standard Date styles (not custom style patterns) and that 

don't use the drop-down list functionality.
Default: On

Edit LongText/Files fields in new windows

If this option is unchecked, trying to edit (e.g. by pressing 
Enter, double-clicking or pressing any character/number key) a 

Long Text or Images/Files field will open the LongText or 

Images/Files view pane to enable users to view/edit the contents.

If this option is checked, trying to edit a Long Text or 

Images/Files field will open an application associated with a 

given file/contents type. Choosing the "Save" command in that 
application will automatically update the data in GS-Base.

Depending on how that edit action is initiated, the following

additional functionality is supported:
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� pressing a digit key opens either the text or the n-th (1...9) 

object for editing 

� pressing a letter key prints either the text or the n-th (a...z) 
object 

Default: Off

Display LongText & Files field contents

If this option is unchecked, the table/form fields related to the

Long Text and Images/Files fields will be displaying text 

containing the number of files, the total size and the last 
modification date/time. (If the Images/Files contains some 

shortcuts to external files, only the number of files is displayed as 

the label.)

If this option is checked, the table/form fields related to the Long 

Text and Images/Files fields will be displaying the contained 

images or file icons with optional labels containing (similarly 
optional) file names, sizes and the last modification dates/times.

Default: Off

Display description of images and files

Specifies whether images and files (icons) in tables/forms should

be displayed along with their general file information which 
includes the file name, size and the last modification date/time.

Default: On

Display images as thumbnails

Specifies whether images and files (icons) in tables/forms should 

be displayed as thumbnails of the specified size.

Default: Off

LongText/Files Editing Settings

Strip off formatting in edited LongText fields
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Text entered in the Long Text fields is saved in the plain UTF-8 

*.txt text format rather than in the rich text *.rtf format.

Using plain text may noticeably reduce memory usage if there is 
a very large number of Long Text entries in the database zip 

file.

Changing this option affect newly entered or edited data only. 

Older entries remain in the previous format until they are edited.
Default: Off

Wrap text in pane

Text displayed in the Long Text fields is wrapped according to 
the width of the view pane.

Default: On

Automatically scroll bottom in LongText fields

By default, after loading LongText fields the beginning of the text 

displayed.

If you check this option, the text cursor will be automatically 

positioned at the bottom of the text.
Default: Off

Display description of images and files

Specifies whether images and files (icons) in Images/Files fields 
should be displayed along with their general file information 

which includes the file name, size and the last modification date.

Default: On

Display images as thumbnails

Specifies whether images and files (icons) in Images/Files fields 

should be displayed as thumbnails of the specified size.
Default: Off
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After closing the database window, GS-Base displays the list of recently used 
databases.

To open a given file, click the corresponding link or press space. 
Alternatively, drag and drop a given file (or files) into that window.

To change the icon associated with a given file, click that icon.

To delete a file from the list, right-click it and use the Remove command 

from the context menu.

If you the activated/clicked file to be moved to the beginning of the list, 

right-click the list and unchecked the Cycle RU List Ring option.

Managing the list of "recently-used" files
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If you have any questions, comments or suggestions, please visit the support forum or e-mail 
Citadel5 directly at info@citadel5.com. 
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